$re = '/[A-Z](?=(?:\'[^\']*\'|[^\'\n])*$)/m';
$str = 'SELECT column_name FROM table_name WHERE column_name IN (\'A\' , \'stu\' ,\'Meyer\', ....);
SELECT column_name FROM table_name WHERE column_name IN (\'A\' , \'stu\' ,\'Meyer\', \'BAR\');';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;