package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<text:.*?>`)
var str = `<text:alphabetical-index-mark-start text:id="IMark169843024"/> asdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> asdfasdfasdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> adsfasdf`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}