// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<text:.*?>").unwrap();
let string = "<text:alphabetical-index-mark-start text:id=\"IMark169843024\"/> asdf <text:alphabetical-index-mark-start text:id=\"IMark169843024\"/> asdfasdfasdf <text:alphabetical-index-mark-start text:id=\"IMark169843024\"/> adsfasdf";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}