const regex = new RegExp('<text:.*?>', 'g')
const str = `<text:alphabetical-index-mark-start text:id="IMark169843024"/> asdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> asdfasdfasdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> adsfasdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);