$re = '~<text:.*?>~';
$str = '<text:alphabetical-index-mark-start text:id="IMark169843024"/> asdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> asdfasdfasdf <text:alphabetical-index-mark-start text:id="IMark169843024"/> adsfasdf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;