using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/(.*)/.*";
string input = @"<a href=""/damm/test1/test2/test3/2345.html"">Test /a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}