$re = ';.*/(.*)/.*;';
$str = '<a href="/damm/test1/test2/test3/2345.html">Test /a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);