re = /.*\/(.*)\/.*/
str = '<a href="/damm/test1/test2/test3/2345.html">Test /a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end