package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*/(.*)/.*`)
var str = `<a href="/damm/test1/test2/test3/2345.html">Test /a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}