const regex = /^.*(Pokémon .*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(Pokémon .*)$', 'gm')
const str = `Pokémon is a media franchise managed by The Pokémon Company, a Japanese consortium between Nintendo, Game Freak, and Creatures.\\nThe franchise began as Pokémon Red and Green (later released outside of Japan as Pokémon Red and Blue).
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}