$re = '/^.*(Pokémon .*)$/m';
$str = 'Pokémon is a media franchise managed by The Pokémon Company, a Japanese consortium between Nintendo, Game Freak, and Creatures.\\nThe franchise began as Pokémon Red and Green (later released outside of Japan as Pokémon Red and Blue).
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);