re = /^.*(Pokémon .*)$/m
str = 'Pokémon is a media franchise managed by The Pokémon Company, a Japanese consortium between Nintendo, Game Freak, and Creatures.\\nThe franchise began as Pokémon Red and Green (later released outside of Japan as Pokémon Red and Blue).
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end