import re
regex = re.compile(r"^.*(Pokémon .*)$", flags=re.MULTILINE)
test_str = ("Pokémon is a media franchise managed by The Pokémon Company, a Japanese consortium between Nintendo, Game Freak, and Creatures.\\nThe franchise began as Pokémon Red and Green (later released outside of Japan as Pokémon Red and Blue).\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")