#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^.*?(is a duplicate for this vendor|Duplicate transaction detected)"
Local $sString = "Number 123456789: Duplicate transaction detected because it is a duplicate for this vendor" & @CRLF & _
"Number 543267890: is a duplicate for this vendor" & @CRLF & _
"Password error number 987654321" & @CRLF & _
"The total can not be negative"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")