using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^.*?(is a duplicate for this vendor|Duplicate transaction detected)";
string input = @"Number 123456789: Duplicate transaction detected because it is a duplicate for this vendor
Number 543267890: is a duplicate for this vendor
Password error number 987654321
The total can not be negative";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}