import re
regex = re.compile(r"(?m)^.*?(is a duplicate for this vendor|Duplicate transaction detected)", flags=re.MULTILINE)
test_str = ("Number 123456789: Duplicate transaction detected because it is a duplicate for this vendor\n"
"Number 543267890: is a duplicate for this vendor\n"
"Password error number 987654321\n"
"The total can not be negative")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")