re = /(?m)^.*?(is a duplicate for this vendor|Duplicate transaction detected)/m
str = 'Number 123456789: Duplicate transaction detected because it is a duplicate for this vendor
Number 543267890: is a duplicate for this vendor
Password error number 987654321
The total can not be negative'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end