$re = '/\\\\([a-z]*)@(?(?<=[a-z]@)[a-z]*$|[a-z]+$)/im';
$str = '\\@
x@
x@x
@x
\\xx
\\@xxx
\\xxx@
\\x@x
\\@x
\\x@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);