import re
regex = re.compile(r"\\([a-z]*)@(?(?<=[a-z]@)[a-z]*$|[a-z]+$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("\\@\n"
"x@\n"
"x@x\n"
"@x\n"
"\\xx\n"
"\\@xxx\n"
"\\xxx@\n"
"\\x@x\n"
"\\@x\n"
"\\x@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")