#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{2}\/\d{2}\/\d{2} +(\S+)"
Local $sString = "SOMEDATA .test 01/45/12 2.50 THIS IS DATA" & @CRLF & _
"SOMEDATA .test 01/45/12 2500 THIS IS DATA" & @CRLF & _
"SOMEDATA .test 01/45/12 $2500 THIS IS DATA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")