// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{2}\/\d{2}\/\d{2} +(\S+)").unwrap();
let string = "SOMEDATA .test 01/45/12 2.50 THIS IS DATA
SOMEDATA .test 01/45/12 2500 THIS IS DATA
SOMEDATA .test 01/45/12 $2500 THIS IS DATA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}