package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2}\/\d{2}\/\d{2} +(\S+)`)
var str = `SOMEDATA .test 01/45/12 2.50 THIS IS DATA
SOMEDATA .test 01/45/12 2500 THIS IS DATA
SOMEDATA .test 01/45/12 $2500 THIS IS DATA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}