const regex = /\d{2}\/\d{2}\/\d{2} +(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}\\\/\\d{2}\\\/\\d{2} +(\\S+)', 'g')
const str = `SOMEDATA .test 01/45/12 2.50 THIS IS DATA
SOMEDATA .test 01/45/12 2500 THIS IS DATA
SOMEDATA .test 01/45/12 \$2500 THIS IS DATA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}