#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(\[\s*\{)?\s*\S*.*\s*(\},\s*\{)?(\}\s*\])?"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "gid": "17âáãoøˆøªª∆∆øˆøˆ˙ˆ©¨ˆ¥ˆ ¨ƒˆƒˆ¥†√ˆ†¥ˆ√"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "lat": "-3.0206756"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "long": "-59.9768139"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "ano_farm_pop": "2014"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "mes_farm_pop": "2"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "ds_endereco_farmacia": "AVENIDA NOEL NUTELS Nº 811"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "nu_cep_farmacia": "69095000"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "uf": "AM"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "cidade": "Manaus"" & @CRLF & _
" }" & @CRLF & _
"]" & @CRLF & _
"[" & @CRLF & _
" {" & @CRLF & _
" "gid": "444"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "lat": "-10.9128701"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "long": "-37.0738442"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "ano_farm_pop": "2014"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "mes_farm_pop": "2"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "ds_endereco_farmacia": "RUA CARLOS CORREIA, 528"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "nu_cep_farmacia": "49075120"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "uf": "SE"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "cidade": "Aracaju"" & @CRLF & _
" }" & @CRLF & _
"]" & @CRLF & _
"[" & @CRLF & _
" {" & @CRLF & _
" "lala": "lele"" & @CRLF & _
" }" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")