import Foundation
let pattern = #"\s*(\[\s*\{)?\s*\S*.*\s*(\},\s*\{)?(\}\s*\])?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[
{
"gid": "17âáãoøˆøªª∆∆øˆøˆ˙ˆ©¨ˆ¥ˆ ¨ƒˆƒˆ¥†√ˆ†¥ˆ√"
},
{
"lat": "-3.0206756"
},
{
"long": "-59.9768139"
},
{
"ano_farm_pop": "2014"
},
{
"mes_farm_pop": "2"
},
{
"ds_endereco_farmacia": "AVENIDA NOEL NUTELS Nº 811"
},
{
"nu_cep_farmacia": "69095000"
},
{
"uf": "AM"
},
{
"cidade": "Manaus"
}
]
[
{
"gid": "444"
},
{
"lat": "-10.9128701"
},
{
"long": "-37.0738442"
},
{
"ano_farm_pop": "2014"
},
{
"mes_farm_pop": "2"
},
{
"ds_endereco_farmacia": "RUA CARLOS CORREIA, 528"
},
{
"nu_cep_farmacia": "49075120"
},
{
"uf": "SE"
},
{
"cidade": "Aracaju"
}
]
[
{
"lala": "lele"
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)