const regex = /\s*(\[\s*\{)?\s*\S*.*\s*(\},\s*\{)?(\}\s*\])?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\[\\s*\\{)?\\s*\\S*.*\\s*(\\},\\s*\\{)?(\\}\\s*\\])?', 'g')
const str = `[
{
"gid": "17âáãoøˆøªª∆∆øˆøˆ˙ˆ©¨ˆ¥ˆ ¨ƒˆƒˆ¥†√ˆ†¥ˆ√"
},
{
"lat": "-3.0206756"
},
{
"long": "-59.9768139"
},
{
"ano_farm_pop": "2014"
},
{
"mes_farm_pop": "2"
},
{
"ds_endereco_farmacia": "AVENIDA NOEL NUTELS Nº 811"
},
{
"nu_cep_farmacia": "69095000"
},
{
"uf": "AM"
},
{
"cidade": "Manaus"
}
]
[
{
"gid": "444"
},
{
"lat": "-10.9128701"
},
{
"long": "-37.0738442"
},
{
"ano_farm_pop": "2014"
},
{
"mes_farm_pop": "2"
},
{
"ds_endereco_farmacia": "RUA CARLOS CORREIA, 528"
},
{
"nu_cep_farmacia": "49075120"
},
{
"uf": "SE"
},
{
"cidade": "Aracaju"
}
]
[
{
"lala": "lele"
}
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}