using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\[\s*\{)?\s*\S*.*\s*(\},\s*\{)?(\}\s*\])?";
string input = @"[
{
""gid"": ""17âáãoøˆøªª∆∆øˆøˆ˙ˆ©¨ˆ¥ˆ ¨ƒˆƒˆ¥†√ˆ†¥ˆ√""
},
{
""lat"": ""-3.0206756""
},
{
""long"": ""-59.9768139""
},
{
""ano_farm_pop"": ""2014""
},
{
""mes_farm_pop"": ""2""
},
{
""ds_endereco_farmacia"": ""AVENIDA NOEL NUTELS Nº 811""
},
{
""nu_cep_farmacia"": ""69095000""
},
{
""uf"": ""AM""
},
{
""cidade"": ""Manaus""
}
]
[
{
""gid"": ""444""
},
{
""lat"": ""-10.9128701""
},
{
""long"": ""-37.0738442""
},
{
""ano_farm_pop"": ""2014""
},
{
""mes_farm_pop"": ""2""
},
{
""ds_endereco_farmacia"": ""RUA CARLOS CORREIA, 528""
},
{
""nu_cep_farmacia"": ""49075120""
},
{
""uf"": ""SE""
},
{
""cidade"": ""Aracaju""
}
]
[
{
""lala"": ""lele""
}
]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}