# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{4}(-)\d{2}(-)\d{4}(:)\d{2}(:)\d{2}//g;t' <<< "\"asd:sdfsdgf-abc2016-08-2212:05:00xyzabc2015-08-2212:05:00xyzabc2014-08-2212:05:00xy-sdf:z\";
"