re = /\d{4}(-)\d{2}(-)\d{4}(:)\d{2}(:)\d{2}/
str = '"asd:sdfsdgf-abc2016-08-2212:05:00xyzabc2015-08-2212:05:00xyzabc2014-08-2212:05:00xy-sdf:z";
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result