const regex = /\d{4}(-)\d{2}(-)\d{4}(:)\d{2}(:)\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}(-)\\d{2}(-)\\d{4}(:)\\d{2}(:)\\d{2}', 'g')
const str = `"asd:sdfsdgf-abc2016-08-2212:05:00xyzabc2015-08-2212:05:00xyzabc2014-08-2212:05:00xy-sdf:z";
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);