use strict;
my $str = '"asd:sdfsdgf-abc2016-08-2212:05:00xyzabc2015-08-2212:05:00xyzabc2014-08-2212:05:00xy-sdf:z";
';
my $regex = qr/\d{4}(-)\d{2}(-)\d{4}(:)\d{2}(:)\d{2}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";