using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((.)(?!\2)(.)(?!\2|\3).$)(?<!^\1$.+)(?!.*^\1$)";
string input = @"abc
aaaa
bcde
acd
abc
abc
xyz
aba
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}