re = /^((.)(?!\2)(.)(?!\2|\3).$)(?<!^\1$.+)(?!.*^\1$)/m
str = 'abc
aaaa
bcde
acd
abc
abc
xyz
aba
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end