$re = '/^((.)(?!\2)(.)(?!\2|\3).$)(?<!^\1$.+)(?!.*^\1$)/ms';
$str = 'abc
aaaa
bcde
acd
abc
abc
xyz
aba
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);