import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.)(?!\\2)(.)(?!\\2|\\3).$)(?<!^\\1$.+)(?!.*^\\1$)";
final String string = "abc\n"
+ "aaaa\n"
+ "bcde\n"
+ "acd\n"
+ "abc\n"
+ "abc\n"
+ "xyz\n"
+ "aba\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}