#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Location:\s\<\/b\>\s)(.+?)(?=\<br\>)"
Local $sString = "<div class="FindBoxTopL fl_left">" & @CRLF & _
"<b>Salary: </b> $10.00 <br>" & @CRLF & _
"<b>Location: </b> Wisconsin Madison<br>" & @CRLF & _
"<b>Country:</b>United States<br>" & @CRLF & _
"" & @CRLF & _
"<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")