import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Location:\\s\\<\\/b\\>\\s)(.+?)(?=\\<br\\>)";
final String string = "<div class=\"FindBoxTopL fl_left\">\n"
+ "<b>Salary: </b> $10.00 <br>\n"
+ "<b>Location: </b> Wisconsin Madison<br>\n"
+ "<b>Country:</b>United States<br>\n\n"
+ "<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}