import re
regex = re.compile(r"(?<=Location:\s\<\/b\>\s)(.+?)(?=\<br\>)")
test_str = ("<div class=\"FindBoxTopL fl_left\">\n"
"<b>Salary: </b> $10.00 <br>\n"
"<b>Location: </b> Wisconsin Madison<br>\n"
"<b>Country:</b>United States<br>\n\n"
"<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")