const regex = /(.*[pP].*[uUÜü@].*[bB].*[iIïÏ1|lL].*[|iIïÏ1lL].*[cC].*[|iIïÏ1lL].*[dD].*[aA4äÄ@Ã].*[dD])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*[pP].*[uUÜü@].*[bB].*[iIïÏ1|lL].*[|iIïÏ1lL].*[cC].*[|iIïÏ1lL].*[dD].*[aA4äÄ@Ã].*[dD])', '')
const str = `publicidad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}