re = /(.*[pP].*[uUÜü@].*[bB].*[iIïÏ1|lL].*[|iIïÏ1lL].*[cC].*[|iIïÏ1lL].*[dD].*[aA4äÄ@Ã].*[dD])/
str = 'publicidad'
# Print the match result
str.match(re) do |match|
puts match.to_s
end