using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FILTER(.*?)ORDER(.*?)(?=FILTER|$)";
string input = @"FILTER
test1
ORDER
test2
FILTER
test3
ORDER
FILTER
ORDER";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}