import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "FILTER(.*?)ORDER(.*?)(?=FILTER|$)";
final String string = "FILTER\n"
+ "test1\n"
+ "ORDER\n"
+ "test2\n"
+ "FILTER\n"
+ "test3\n"
+ "ORDER\n"
+ "FILTER\n"
+ "ORDER";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}