re = /FILTER(.*?)ORDER(.*?)(?=FILTER|$)/
str = 'FILTER
test1
ORDER
test2
FILTER
test3
ORDER
FILTER
ORDER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end