$re = '/FILTER(.*?)ORDER(.*?)(?=FILTER|$)/s';
$str = 'FILTER
test1
ORDER
test2
FILTER
test3
ORDER
FILTER
ORDER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);