using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(\\\""))(\:)([0-9\.]+)(\,)";
string input = @"""time"":1430702635,\""id\"":\""45\"",\""state\"":2,""stamp"":1430702635,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}