re = /(?!(\\\"))(\:)([0-9\.]+)(\,)/
str = '"time":1430702635,\\"id\\":\\"45\\",\\"state\\":2,"stamp":1430702635,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end