$re = '/(?!(\\\\\"))(\:)([0-9\.]+)(\,)/';
$str = '"time":1430702635,\\"id\\":\\"45\\",\\"state\\":2,"stamp":1430702635,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);