import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(\\\\\\\"))(\\:)([0-9\\.]+)(\\,)";
final String string = "\"time\":1430702635,\\\"id\\\":\\\"45\\\",\\\"state\\\":2,\"stamp\":1430702635,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}