#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(.*?)\s*\(BlockID:\s*(\d+),TestCaseID:\s*(\d+)"
Local $sString = " SomeText SomeText SomeText SomeText SomeText " & @CRLF & _
"SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText." & @CRLF & _
"SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText." & @CRLF & _
"SomeText SomeText :" & @CRLF & _
"SomeText SomeText SomeText SomeText SomeText SomeText (BlockID: 12345,TestCaseID: 12345, 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")