import re
regex = re.compile(r"(?s)(.*?)\s*\(BlockID:\s*(\d+),TestCaseID:\s*(\d+)")
test_str = (" SomeText SomeText SomeText SomeText SomeText \n"
"SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.\n"
"SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText SomeText.\n"
"SomeText SomeText :\n"
"SomeText SomeText SomeText SomeText SomeText SomeText (BlockID: 12345,TestCaseID: 12345, 1)")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")